All Far3 plugins crash

Here you can discuss about your favorite plug-in.
Post Reply
pandronic
Posts: 30
Joined: Tue 23 Mar, 2010 12:04

All Far3 plugins crash

Post by pandronic » Tue 09 Oct, 2012 07:35

I've used the renewal plugin to keep Far and my plugins up to date. A few weeks ago, I've updated Far 3 to the latest version and this is what I get every time I start it:
Since then, I've uninstalled Far and Conemu, deleted the Far folder with all the old plugins and did a clean install of Far3 and ConEmu (latest versions). The same happens. Also, almost all plugins like Netbox, Colorer and MBlockEditor don't work (latest Far3 versions of the plugins - that were working before).

Ideas?
Last edited by pandronic on Thu 01 Jan, 1970 01:00, edited 0 times in total.
Reason: Hidden an excessive poor screenshot

2useven10
Posts: 3045
Joined: Mon 07 Sep, 2009 10:40
Has thanked: 2 times
Been thanked: 83 times

Re: All Far3 plugins crash

Post by 2useven10 » Tue 09 Oct, 2012 10:10

Plugin API changed, so many plugins are not ready to work with latest far.
But Colorer, Netbox and ConEmu should work if you use really latest version.

User avatar
HaRT
Moderator
Posts: 8118
Joined: Tue 30 Aug, 2005 17:21
Location: Санкт-Петербург
Has thanked: 68 times
Been thanked: 106 times

Post by HaRT » Tue 09 Oct, 2012 12:45

pandronic
Use the AltIns shortcut to grab selective text from FAR window and

Code: Select all

[/b] BBCode tag to insert the grabbed text here.
Фар есть инструмент, а не нянька. © 2009 DrKnS

pandronic
Posts: 30
Joined: Tue 23 Mar, 2010 12:04

Re: All Far3 plugins crash

Post by pandronic » Tue 09 Oct, 2012 15:21

Code: Select all

                               │      ║║

    ╔════════════════════════ Exception occurred ════════════════════════╗
    ║ Exception:   Access violation (execute at 0x0000000A)              ║
    ║ Address:     0x00000000                                            ║
    ║ Function:    SetStartupInfoW                                       ║
    ║ Module:      C:\Program Files\Far Manager\Plugins\ConEmu.dll       ║
    ╟────────────────────────────────────────────────────────────────────╢
    ║                    { Unload plugin } [ Debug ]                     ║
    ╚════════════════════════════════════════════════════════════════════╝

                               │      ║║
@Hart: Updated screenshot
@2useven10: I've downloaded Far & ConEmu this morning. Far is build 2876 x86 and ConEmu is 120727c x86

2useven10
Posts: 3045
Joined: Mon 07 Sep, 2009 10:40
Has thanked: 2 times
Been thanked: 83 times

Re: All Far3 plugins crash

Post by 2useven10 » Tue 09 Oct, 2012 15:57

ConEmu is 120727c x86
tooo old
latest here

pandronic
Posts: 30
Joined: Tue 23 Mar, 2010 12:04

Re: All Far3 plugins crash

Post by pandronic » Wed 10 Oct, 2012 07:43

I've downloaded the latest ConEmu - ConEmuSetup.121009.exe and latest Far3 nightly Far30b2876.x86.20121008.msi and when trying to Drag n'Drop a file from Far all hell breaks loose:

Code: Select all

╔══════════════ Error parsing macro ═══════════════╗
║ [string "MsLClick"]:1: '=' expected near '<eof>' ║
╟──────────────────────────────────────────────────╢
║                      { OK }                      ║
╚══════════════════════════════════════════════════╝

╔════════════════════════ Exception occurred ════════════════════════╗
║ Exception:   Access violation (read from 0x0A006BA2)               ║
║ Address:     0x76BD3C71                                            ║
║ Function:    ProcessSynchroEventW                                  ║
║ Module:      C:\Program Files\Far Manager\Plugins\ConEmu.dll       ║
╟────────────────────────────────────────────────────────────────────╢
║                    { Unload plugin } [ Debug ]                     ║
╚════════════════════════════════════════════════════════════════════╝
I think I'll go back to Far2 for a while, Far3 seems kinda unstable these days. Hope I can still find all my plugins for Far2 :( Oh, boy, Russian forums and Google Translate here I come ...

Shmuel
Posts: 5230
Joined: Thu 23 Mar, 2006 21:36
Location: Israel
Has thanked: 16 times
Been thanked: 151 times

Re: All Far3 plugins crash

Post by Shmuel » Wed 10 Oct, 2012 08:19

pandronic wrote:

Code: Select all

╔══════════════ Error parsing macro ═══════════════╗
║ [string "MsLClick"]:1: '=' expected near '<eof>' ║
╟──────────────────────────────────────────────────╢
║                      { OK }                      ║
╚══════════════════════════════════════════════════╝
This is due to the recent change from "macro language" to Lua.
The author has to replace "MsLClick" with "Keys('MsLClick')".

2useven10
Posts: 3045
Joined: Mon 07 Sep, 2009 10:40
Has thanked: 2 times
Been thanked: 83 times

Re: All Far3 plugins crash

Post by 2useven10 » Wed 10 Oct, 2012 08:33

I think I'll go back to Far2 for a while, Far3 seems kinda unstable these days. Hope I can still find all my plugins for Far2 Oh, boy, Russian forums and Google Translate here I come ...
You can just downgrade to far3 build 2798. It is last build before plugin api changed.
But in that case you cannot use latest (adapted to api changes) plugins.
Old far build collection you can find here

pandronic
Posts: 30
Joined: Tue 23 Mar, 2010 12:04

Re: All Far3 plugins crash

Post by pandronic » Thu 11 Oct, 2012 06:58

Cool, thanks

Post Reply

Return to “General Plug-In Discussions”