Bookmark-macro with "[LR]CtrlShift0" in Editor doesn't work

You have encountered a problem using Far macros? Here you can get help.
farman
Posts: 118
Joined: Thu 03 Sep, 2009 11:32

Bookmark-macro with "[LR]CtrlShift0" in Editor doesn't work

Postby farman » Thu 22 Jan, 2015 07:05

This macro replaces the original keys "set/goto bookmark" in Editor. Everything works fine except set bookmark with "[LR]CtrlShift0" which does nothing. Goto Bookmark with "[LR]Ctrl0" works. Any Ideas? Maybe a national (german) keyboard problem again?

Code: Select all

Macro { description="Set Bookmark in Editor with (RCtrlShift, LCtrlShift)";
        area="Editor Viewer"; key="/[LR]CtrlShift[0-9]/"; flags="";
        action = function()    Keys('CtrlShift' .. akey(1):sub(-1))    end; }

Macro { description="Goto Bookmark in Editor with (RCtrl, LCtrl)";
        area="Editor Viewer"; key="/[LR]Ctrl[0-9]/"; flags="";
        action = function()    Keys('Ctrl' .. akey(1):sub(-1))    end; }

Shmuel
Posts: 4952
Joined: Thu 23 Mar, 2006 21:36
Location: Israel
Has thanked: 11 times
Been thanked: 123 times

Bookmark-macro with "[LR]CtrlShift0" in Editor doesn't work

Postby Shmuel » Thu 22 Jan, 2015 07:20

1. The above macros work for me.
2. Try to insert far.Message(akey(1)) in the action of the first macro to see if it is called.
3. Try flags="NoSendKeysToPlugins";

farman
Posts: 118
Joined: Thu 03 Sep, 2009 11:32

Bookmark-macro with "[LR]CtrlShift0" in Editor doesn't work

Postby farman » Thu 22 Jan, 2015 07:43

Thanks for your advice, Shmuel. Here are the results:
- Macro isn't called (2).
- Flag doesn't change anything.
Macro was tested in a clean FAR.

Shmuel
Posts: 4952
Joined: Thu 23 Mar, 2006 21:36
Location: Israel
Has thanked: 11 times
Been thanked: 123 times

Bookmark-macro with "[LR]CtrlShift0" in Editor doesn't work

Postby Shmuel » Thu 22 Jan, 2015 07:51

farman wrote:Source of the post Macro isn't called
I hope you reloaded either macros or Far before testing the modified macros?

Shmuel
Posts: 4952
Joined: Thu 23 Mar, 2006 21:36
Location: Israel
Has thanked: 11 times
Been thanked: 123 times

Bookmark-macro with "[LR]CtrlShift0" in Editor doesn't work

Postby Shmuel » Thu 22 Jan, 2015 08:15

farman, you can test the names of keys and key combinations as follows:
1. Press Ctrl.Ctrl.
2. Press some key (e.g. CtrlShift3) - you should be able to see its name in the dialog field

Repeat (2) as many times as needed with various keys.

farman
Posts: 118
Joined: Thu 03 Sep, 2009 11:32

Bookmark-macro with "[LR]CtrlShift0" in Editor doesn't work

Postby farman » Thu 22 Jan, 2015 08:25

Every key Combination on "0" is working except "[LR]CtrlShift0".
Restarted Far, restarted PC, several PC...

farman
Posts: 118
Joined: Thu 03 Sep, 2009 11:32

Bookmark-macro with "[LR]CtrlShift0" in Editor doesn't work

Postby farman » Thu 22 Jan, 2015 08:29

The keycombination was working well for a long time, but some far-versions ago it stopped.

Shmuel
Posts: 4952
Joined: Thu 23 Mar, 2006 21:36
Location: Israel
Has thanked: 11 times
Been thanked: 123 times

Bookmark-macro with "[LR]CtrlShift0" in Editor doesn't work

Postby Shmuel » Thu 22 Jan, 2015 08:41

You mean CtrlShift0 stopped working?
As it does work for me with the latest Far build I can not test when it "stopped working". It is your responsibility: http://farmanager.com/nightly.php

User avatar
DrKnS
Posts: 4458
Joined: Thu 04 Aug, 2005 06:44
Location: Kyiv
Has thanked: 2 times
Been thanked: 105 times
Contact:

Bookmark-macro with "[LR]CtrlShift0" in Editor doesn't work

Postby DrKnS » Thu 22 Jan, 2015 08:50

Try this.

farman
Posts: 118
Joined: Thu 03 Sep, 2009 11:32

Bookmark-macro with "[LR]CtrlShift0" in Editor doesn't work

Postby farman » Thu 22 Jan, 2015 08:59

Oh, crazy. Maybe a Windows bug? I've changed keyboard/region settings to test for national keyboard-problems and now, after switching back to german, the keycombination is working again. This doesn't really make any sense since the problem exists on several PCs. I will test that on the other PCs too...

UPDATE: Reserved key for switching language in several windows version. Thanks , DrKnS.


Return to “Support and Troubleshooting”

Who is online

Users browsing this forum: No registered users and 1 guest