Search found 117 matches

by KlepetoX
Mon 09 Sep, 2019 14:33
Forum: General Plug-In Discussions
Topic: arclite - 7-Zip backed plug-in for handling archives
Replies: 32
Views: 31367

arclite - 7-Zip backed plug-in for handling archives

DrKnS:
KlepetoX, you can use arc:"\"c:\archive\right archive.zip\""
Though I don't understand it at all, it works well. Great solution. Thank you...
by KlepetoX
Mon 09 Sep, 2019 08:00
Forum: General Plug-In Discussions
Topic: arclite - 7-Zip backed plug-in for handling archives
Replies: 32
Views: 31367

arclite - 7-Zip backed plug-in for handling archives

Hi, I have a macro, where I start another copy of FAR with actual left and right panel path, or open archive. There's a problem with archives with spaces in the file name. See example: far.exe "c:\left path" arc:"c:\archive\right archive.zip" far.exe "c:\left path" arc:"c:\archive\rightarchive.zip" ...
by KlepetoX
Wed 02 Jan, 2019 15:54
Forum: Suggestions and Ideas
Topic: Cmdline far:new ?
Replies: 1
Views: 6362

Cmdline far:new ?

That would be great feature. I used macro for this reason, but it is not perfect. Cursor position and plugin panels (except of ArcLite) are ignored... It uses ConEmu, but you can make small change to run Far.exe directly. Macro { key ="CtrlAltO"; area ="Common"; description ="Clone Far"; action=func...
by KlepetoX
Sun 18 Nov, 2018 08:02
Forum: Support and Troubleshooting
Topic: Fast find in panels window - strange behavior
Replies: 9
Views: 5505

Fast find in panels window - strange behavior

Far 5319, the problem has arisen again. Or am I doing something in a wrong way?
by KlepetoX
Fri 16 Nov, 2018 10:12
Forum: Support and Troubleshooting
Topic: Fast find in panels window - strange behavior
Replies: 9
Views: 5505

Fast find in panels window - strange behavior

DrKnS - I tried 5315, 5316 is ok. Solved, thanks...
by KlepetoX
Fri 16 Nov, 2018 07:40
Forum: Support and Troubleshooting
Topic: Fast find in panels window - strange behavior
Replies: 9
Views: 5505

Fast find in panels window - strange behavior

Thanks for the quick correction. But there's another very bad thing. When I display the fast find window and type several characters, cursor in panel moves correctly to typed folder. But when I press Enter, fast find window disapears, but Enter is ignored, instead of the change directory. I must pre...
by KlepetoX
Wed 14 Nov, 2018 15:42
Forum: Support and Troubleshooting
Topic: Fast find in panels window - strange behavior
Replies: 9
Views: 5505

Fast find in panels window - strange behavior

I have found some strange behavior when fast find window is closed by clicking mouse outside this window (on panel...). After closing this window, space character is inserted in command line, I must press Escape or Backspace to delete it. I have found older version 4472 and everything is ok there.
by KlepetoX
Sun 23 Sep, 2018 17:05
Forum: Support and Troubleshooting
Topic: Macro Browser problem
Replies: 5
Views: 5483

Macro Browser problem

Yes, you are absolutely right, I changed it and call it with 2 arguments now. But when I delete macro PickPathFromOtherFAR.lua, second argument is not necessary. I thought that problem is in new FAR version, but originated by downloading that macro. Now, with 2 arguments is everything OK.
by KlepetoX
Sun 23 Sep, 2018 16:09
Forum: Support and Troubleshooting
Topic: Macro Browser problem
Replies: 5
Views: 5483

Macro Browser problem

Thanks, works perfectly. I tried to find the reason and have found it. First I deleted all plugins except of Macro Browser, nothing happend, still doesn't work. Then I tried delete some newer macros - and the problem is caused by macro PickPathFromOtherFAR.lua http://forum.farmanager.com/viewtopic.p...
by KlepetoX
Sun 23 Sep, 2018 14:42
Forum: Support and Troubleshooting
Topic: Macro Browser problem
Replies: 5
Views: 5483

Macro Browser problem

I call Macro Browser from some macros, now it has stopped working: Far 5201 works well, command: Plugin.Menu("4EBBEFC8-2084-4B7F-94C0-692CE136894D") correctly shows Macro Browser Far 5261 doesn't work: Plugin.Menu("4EBBEFC8-2084-4B7F-94C0-692CE136894D") shows nothing, if I evaluate expression, the r...
by KlepetoX
Thu 25 Jan, 2018 13:15
Forum: General Plug-In Discussions
Topic: PictureView ConEmu drag&drop problem
Replies: 1
Views: 6426

PictureView ConEmu drag&drop problem

I have found following thing to reproduce the problem: Call plugin PictView3 from plugin menu or with file association on Enter with plugin prefix pic:"!.!" - then Title of FAR window (with or without ConEmu) is not refreshed, drag & drop stopped work in ConEmu until a directory is changed Call plug...
by KlepetoX
Tue 23 Jan, 2018 16:21
Forum: Операционные системы, командные оболочки и прочее
Topic: ConEmu: Console Emulator — эмулятор консоли
Replies: 1614
Views: 685184

ConEmu: Console Emulator — графическая консоль

There's an error with latest version of ConEmu. The error is invoked by function Far.KbdLayout(): -- Switching keyboards needs these registry setting: -- [HKEY_CURRENT_USER\Console] -- "ForceV2"=dword:00000000 Macro { key="CtrlK"; area="Common"; description="Switch keyboard to English"; action=funct...
by KlepetoX
Sat 16 Dec, 2017 12:18
Forum: Обсуждение макросов
Topic: Как правильно применить kbdLayout()?
Replies: 19
Views: 14140

Как правильно применить kbdLayout()?

I have this note with my switching keyboard macro and it works:

Switching keyboards needed these registry setting (old console):
[HKEY_CURRENT_USER\Console]
ForceV2=dword:00000000
by KlepetoX
Fri 20 Oct, 2017 07:36
Forum: General Plug-In Discussions
Topic: PictureView ConEmu drag&drop problem
Replies: 1
Views: 6426

PictureView ConEmu drag&drop problem

After view any picture, ConEmu drag and drop function doesn't work until directory change or go to passive panel and back.

Also FAR window title is not refreshed (even in FAR without ConEmu):
Image
by KlepetoX
Fri 13 Oct, 2017 15:57
Forum: Support and Troubleshooting
Topic: Bad macro drawing in editor
Replies: 1
Views: 6704

Bad macro drawing in editor

I use macro Align Block Special (http://forum.farmanager.com/viewtopic.php?f=35&t=7965) and it is broken in latest FAR versions. Version 5000 is still correct.

Far 5000
Image

Newest FAR
Image

What's wrong. Something with me or FAR?

Go to advanced search