.NET: на какую версию ориентироваться?

Здесь обсуждаются темы, косвенно связанные с Far.
User avatar
NightRoman
Posts: 5911
Joined: Fri 18 Aug, 2006 13:52
Location: Cambridge, UK
Has thanked: 10 times
Been thanked: 11 times
Contact:

Re: .NET: на какую версию ориентироваться?

Post by NightRoman » Wed 06 Jul, 2011 15:28

Latest post of the previous page:

Впрочем они и для 4-ки просто написали XP без пояснений, так что хотелось бы уточнить это дело. Ну это я и сам могу нагуглить, конечно.

User avatar
lordmuzer
Posts: 522
Joined: Mon 12 Nov, 2007 22:05
Location: Киев
Contact:

Re: .NET: на какую версию ориентироваться?

Post by lordmuzer » Wed 06 Jul, 2011 16:15

тут: http://msdn.microsoft.com/en-us/library/8z6watww.aspx
For all platforms, we recommend that you upgrade to the latest Windows Service Pack and critical updates available from the Windows Update Web site to ensure the best compatibility and security. Installation of the latest Windows Service Pack may be required on some operating systems.

User avatar
NightRoman
Posts: 5911
Joined: Fri 18 Aug, 2006 13:52
Location: Cambridge, UK
Has thanked: 10 times
Been thanked: 11 times
Contact:

Re: .NET: на какую версию ориентироваться?

Post by NightRoman » Thu 07 Jul, 2011 20:38

Народ поругивает так называемые Client Profile версии, как 3.5, так и 4.0.

Поначалу может показаться привлекательным поставить "поменьше". (В случае с 4.0 нелепо экономить вообще: полная версия 48 мегов, а клиент 41 мег). А потом рано или поздно оказывается, что находится программа или, скажем, PowerShell скрипт, которые пользуют невинные вполне пригодные для клиента методы из System.Web для кодирования и раскодирования HTML текста (они и для XML вполне годятся) или чтобы скачку файла организовать (далеко не пойдем за примером - PowerShellFar имеет скрипт для апдейта FarNet и PowerShellFar). И тогда - упс.

ВАЖНО:
Если Automatic Windows Update включен (во всяком случае на Windows 7), то .NET 4.0 автоматом установится именно Client Profile. Так что либо лучше поглядывать на эти апдейты и отказаться от такой услуги, либо сразу уж скачать один раз полную версию 4-ки и поставить ее еще до апдейтов, проблем или хлопот в будущем будет потенциально меньше.

Резюме: ставьте полные версии, если не ищете приключений.

Kildor
Posts: 1515
Joined: Wed 16 Mar, 2005 06:26
Location: Новосибирск
Contact:

Re: .NET: на какую версию ориентироваться?

Post by Kildor » Fri 08 Jul, 2011 03:57

О. Кстати вопрос. В WinXP sp3 .нет входит в комплект? И если нет — как его правильно ставить?
Ты мне не выкай!
«ФарФорум не для пользователей!»
Upd:
P.S. Я просто поддерживаю беседу.» © Народ.

xmpp:kildor@jabber.ru

User avatar
NightRoman
Posts: 5911
Joined: Fri 18 Aug, 2006 13:52
Location: Cambridge, UK
Has thanked: 10 times
Been thanked: 11 times
Contact:

Re: .NET: на какую версию ориентироваться?

Post by NightRoman » Fri 08 Jul, 2011 04:42

Kildor wrote:О. Кстати вопрос. В WinXP sp3 .нет входит в комплект? И если нет — как его правильно ставить?
Нет, не входит, никакая версия (но может и оказаться по разным причинам, если машина уже пользовалась).

Конкретно для FarNet я бы качал и ставил .NET 4.0 (он новее, да и дистрибутив гораздо меньше, чем у 3.5, как ни странно). Хотя target framework у FarNet - 3.5, но сконфигурирован он запускаться под 4.0, если таковой имеется, так что настраивать ничего не придется. FarNet на 4.0 тестируется, работать должен. Если не только для FarNet .NET планируется, то ответ может зависеть от конкретных приложений. По идее, большинство собранных для 2-3.x должны работать без проблем, но гарантий нет, так как тонкие отличия в рантайме 4.0 имеются. (Но вообще, добавлю, что личного опыта установки .NET 4.0 на XP sp3 нет).

Еще момент. Если планируется ставить Visual Studio (2008 или 2010), то надо просто поставить студию. Соответствующий студии .NET при этом поставится.

User avatar
zg
zero-gravity
Posts: 5542
Joined: Tue 15 Mar, 2005 17:36
Location: riga
Been thanked: 85 times
Contact:

Re: .NET: на какую версию ориентироваться?

Post by zg » Wed 07 Sep, 2011 20:16

кстати как минимум 2003-му серверу не даются никакие другие обновления, пока .net 3.5 не поставишь.

Post Reply

Return to “Операционные системы, командные оболочки и прочее”