FAR 2.0 - upgrade or not?

You want to talk about Far Manager, but don't know where to turn?
Post Reply
pepak
Posts: 372
Joined: Sun 13 Jul, 2008 11:18
Has thanked: 5 times
Been thanked: 11 times

FAR 2.0 - upgrade or not?

Post by pepak » Sat 07 Mar, 2009 09:42

I am sure it is written somewhere in the Russian section of the forum, but unfortunately that's very difficult for me to read and even more difficult to search:

What features does FAR 2.0 have that are not present in the 1.7x branch? I know of:
- open source (irrelevant for me)
- unicode support (not really important for me in filesystem, though I would find that useful in viewer and editor)

What would I have to sacrifice? I expect:
- old plugins won't work anymore (big problem for me, as many of those plugins are no longer maintained but very useful for me)

Considering this, I am inclined to stick with 1.7x, but I am sure FAR 2.0 has many features that would be quite interesting for me, if I only knew which they were.

User avatar
Px
Posts: 826
Joined: Fri 08 Sep, 2006 15:52
Location: Вишнёвый (под Киевом)
Contact:

Re: FAR 2.0 - upgrade or not?

Post by Px » Sat 07 Mar, 2009 11:44

pepak wrote: - old plugins won't work anymore (big problem for me, as many of those plugins are no longer maintained but very useful for me)
Some of the old plugins won't work (for example SearchAndReplace, SSA Editor), but some - will (Colorer, Conman, FarNetStat, SmartLaunch, etc...). Also some of the plugins have special versions for Far 2.0, you can find them here - http://forum.farmanager.com/viewforum.php?f=11
You can easily try Far 2.0 and it's compatibility with you plugins because it store settings in other registry hive then 1.7x branch, so you main installation will be unaffected :)

twodev
Posts: 55
Joined: Mon 23 Feb, 2009 00:36

Re: FAR 2.0 - upgrade or not?

Post by twodev » Sat 07 Mar, 2009 13:12

Honestly, most of the old plugins which are really useful still work with FAR 2. And the ones that don't can be replaced (or there are new versions somewhere in the Russian plugin announcement forum). Sometimes emailing the author helps as well, for example Victor Derevyanko mailed me his wonderful Named Folders plugin.

But take your time migrating your old setup, it's worth it.

Also, as Px said, FAR 2 stores its settings in a different registry location, ie. HKCU\Software\Far2 rather than HKCU\Software\Far, which makes it easy to try it without breaking your current FAR 1 installation.
far2 plugins: format menu (discuss) | editor tools (discuss); far2 tools: lngtool

pepak
Posts: 372
Joined: Sun 13 Jul, 2008 11:18
Has thanked: 5 times
Been thanked: 11 times

Re: FAR 2.0 - upgrade or not?

Post by pepak » Tue 10 Mar, 2009 18:49

Well, that's part one - overcoming incompatibilities. What about the part 2 - what would be the reasons to move to FAR 2.0? As of now, I only know of the two I listed above. What other new features does the new FAR have?

Игорь Юдинцев
Posts: 725
Joined: Sun 03 Apr, 2005 22:00
Location: Казань
Been thanked: 1 time

Re: FAR 2.0 - upgrade or not?

Post by Игорь Юдинцев » Tue 10 Mar, 2009 19:05

pepak
I'd also mention the support for regular expressions in selection masks.

joejoe
Posts: 7
Joined: Wed 16 Apr, 2008 08:13
Location: Czech Republic
Contact:

Re: FAR 2.0 - upgrade or not?

Post by joejoe » Wed 11 Mar, 2009 16:54

pepak wrote:Well, that's part one - overcoming incompatibilities. What about the part 2 - what would be the reasons to move to FAR 2.0? As of now, I only know of the two I listed above. What other new features does the new FAR have?
Actually, the only reason to stay with old version is a compatibility of plugins.

The reasons why to switch are following:
- you can at least report problems of 2.0
- you can use the both of versions (there is no risk/configuration is in separated registry subtree - "Far2")
- the effort consumed by maintaining of two branches of development is bigger then effort for single branch maintenance. The focus of developers is also depended on count of users.
- unicode support is necessary for me (at least i can open/copy/delete files with strange file names)
- being up to date is mostly good (new features, fixed bugs, but sometimes update breaks your system) - i like the update plugin
- and of course it is just "cool" (-;

I am thinking, that some mentioned here, that the only problem with releasing 2.0 with installer is English localization ( i am not sure, just kind of feeling )

User avatar
t-rex
Страшный и ужасный
Posts: 4899
Joined: Tue 15 Mar, 2005 16:17
Location: Tel-Aviv
Has thanked: 1 time
Contact:

Re: FAR 2.0 - upgrade or not?

Post by t-rex » Wed 11 Mar, 2009 17:23

joejoe
2.0 is really an alpha and not release material.

joejoe
Posts: 7
Joined: Wed 16 Apr, 2008 08:13
Location: Czech Republic
Contact:

Re: FAR 2.0 - upgrade or not?

Post by joejoe » Wed 11 Mar, 2009 18:39

t-rex wrote:joejoe
2.0 is really an alpha and not release material.
it was just feeling, because far2 is pretty stable.. maybe it was about releasing of betaversion with installer

JimWilson
Posts: 28
Joined: Tue 22 Apr, 2008 00:50

Re: FAR 2.0 - upgrade or not?

Post by JimWilson » Wed 18 Mar, 2009 13:38

pepak; I'm like you, looking to see if there's any reason to abandon 1.7x in favor of 2.0. So far, this thread doesn't really mention anything specific, other then unicode (which isn't something that interests me).

As far as the plugins go... it's nice to know I can test the new version without impacting the one I'm currently using, which is a huge benefit. But like you I've been using some plugins for years, and would be completely lost without them (multi-panel, for example). I've tried to contact many of the authors for these older plugins in the past, to see if a more current version was available, but my success rate has been very small. Either the email address is no longer valid, or I never receive a reply. I'm afraid there are some plugins I can't live without, so unless they work with 2.0 I won't be upgrading. But I may give the new version a try, just to see what plugins do work and which don't.

pepak
Posts: 372
Joined: Sun 13 Jul, 2008 11:18
Has thanked: 5 times
Been thanked: 11 times

Re: FAR 2.0 - upgrade or not?

Post by pepak » Wed 18 Mar, 2009 13:51

Well, I do find it reassuring that some plugins might still work. But at the moment I am still not sure just why would I want to upgrade. I mean, the only two new things that I know of are irrelevant for me, so at the moment it seems that I would be upgrading for the sake of upgrading, without getting any clear benefit. A list of new stuff would certainly help in this, because it would surely contain items that would be useful for me if I only realized what they were - I mean, something like "FAR now supports XYZ" that would make me jump and realize that that's precisely what slows me down in 1.7 version.

User avatar
sicvolo
Posts: 119
Joined: Tue 05 Feb, 2008 01:47

Re: FAR 2.0 - upgrade or not?

Post by sicvolo » Thu 16 Apr, 2009 06:31

I'd say if you do not care about unicode, don`t upgrade. Alpha still has bugs being ironed out daily. Wait for the beta, by that time plugins that are still maintained might be upgraded to support 2.0 natively.
However, if you do feel adventurous, there is an "update" plugin that will keep your Far updated with the latest build from the "nightly releases" page.
ФАРева

Post Reply

Return to “General Discussions”