Page 2 of 2

Re: Far 3 significantly slower

Posted: Wed 10 Apr, 2013 10:25
by soso

Latest post of the previous page:

t-rex wrote:Done, does it feel better?
I just upgraded to latest nightly build and yes it's better. One q, the history is still saved in db?

Re: Far 3 significantly slower

Posted: Wed 10 Apr, 2013 10:38
by t-rex
Yes, nothing changed, it's just async.

Re: Far 3 significantly slower

Posted: Fri 28 Feb, 2014 21:20
by pepak
I have just decided to switch to FAR3, and unfortunately the loss of speed hit me very hard: Just about everything is significantly slower now, especially startup. Intolerably so - I have to return to FAR2 :-(

Re: Far 3 significantly slower

Posted: Fri 28 Feb, 2014 21:37
by Shmuel
pepak wrote:Just about everything is significantly slower now, especially startup. Intolerably so - I have to return to FAR2 :-(
What is "intolerably" measured in seconds?
My copy of Far 3 starts up in less than 1 second (assuming it is not the first start after Windows reboot).

Re: Far 3 significantly slower

Posted: Fri 28 Feb, 2014 21:40
by pepak
As many as two seconds for a startup (from a ramdisk!), very noticeable (though hard to measure) delays during filesystem traversal.

Re: Far 3 significantly slower

Posted: Fri 28 Feb, 2014 22:32
by 2useven10
(from a ramdisk!)
So far.exe started from ramdisk and probably %FARHOME% points to ramdisk.
But where are far configuration databases (%FARPROFILE%, %FARLOCALPROFILE%) ?
Type "set far" in far commandline and analize results...
Maybe %FARPROFILE% points to corporate network drive or slowly flashdrive...

Re: Far 3 significantly slower

Posted: Sat 01 Mar, 2014 08:28
by pepak
2useven10 wrote:
(from a ramdisk!)
So far.exe started from ramdisk and probably %FARHOME% points to ramdisk.
But where are far configuration databases (%FARPROFILE%, %FARLOCALPROFILE%) ?
Also ramdisk.

I rather suspect the SQLite database backend, which gets called again for every history item. Possibly when used in situations with multiple FAR Managers running, under different Windows users, but with the same profile (e.g. I have a FAR running as Pepak, a FAR running as Administrator, etc., all of them with the same FARPROFILE). This suspicion is further compounded by the fact that late yesterday SQLite suddenly went crazy and stopped sending any data for plugins, even though the same SQLite database when viewed with SQLiteSpy showed correct content.