Resolving network names in command line

You have encountered a problem using Far Manager? Here you can get help.
Post Reply
blabulabul
Posts: 10
Joined: Mon 10 Sep, 2012 14:37

Resolving network names in command line

Post by blabulabul » Fri 21 Sep, 2018 09:50

Is it possible to turn off resolving DN in command line? Sometimes it hangs for a long time while typing something like "\\abcd\...".

User avatar
HaRT
Moderator
Posts: 9156
Joined: Tue 30 Aug, 2005 17:21
Location: Санкт-Петербург
Has thanked: 90 times
Been thanked: 174 times

Resolving network names in command line

Post by HaRT » Fri 21 Sep, 2018 11:57

Not exactly what you ask for, but you can turn AutoComplete off completely (pun intended) in Command Line settings (via the Options menu).
Фар есть инструмент, а не нянька. © 2009 DrKnS

blabulabul
Posts: 10
Joined: Mon 10 Sep, 2012 14:37

Resolving network names in command line

Post by blabulabul » Fri 21 Sep, 2018 12:58

Yes, disabling AutoComplete will cause disable resolving DN too, but I don't want to disable AutoComplete.

You can try writing to the command line "cd \\something\boo" and while writing Far will try to resolve "something" as network name, so writing backslash before "boo" will freeze for a few second.

2useven10
Posts: 3983
Joined: Mon 07 Sep, 2009 10:40
Has thanked: 4 times
Been thanked: 173 times

Resolving network names in command line

Post by 2useven10 » Fri 21 Sep, 2018 13:46

You can start autocomplete manually via Ctrl+Space even if Cmdline Autocomplete disabled.

User avatar
Xerox
Posts: 250
Joined: Sun 20 Oct, 2019 15:50
Has thanked: 246 times
Been thanked: 2 times

Resolving network names in command line

Post by Xerox » Mon 25 Nov, 2019 12:18

blabulabul, you totally have not to turn off auto-complete completely.
Your just make this config:

Code: Select all

Cmdline.AutoComplete                      │boolean│true
Dialog.AutoComplete                       │boolean│true
Interface.Completion.Append               │boolean│false
Interface.Completion.ModalList            │boolean│false
Interface.Completion.ShowList             │boolean│true
Interface.Completion.UseEnvironment       │3-state│true
Interface.Completion.UseFilesystem        │3-state│OTHER
Interface.Completion.UseHistory           │3-state│true
Interface.Completion.UsePath              │3-state│true
See OTHER value for "Interface.Completion.UseFilesystem",
it will make the difference you need (being stuck on network paths),
while not affecting other stuff.
And you still also may use Ctrl+space to explicitly call all the auto-complete you may need
Last edited by Xerox on Mon 25 Nov, 2019 12:20, edited 2 times in total.

Post Reply

Return to “Support and Troubleshooting”