Page 1 of 1

CHM file not opened in FAR 3 Build 5254 x64 from user menu

Posted: Wed 03 Oct, 2018 07:12
by tomyam
In my user menu, I have chm files entered as follows, c:\fwh\manual\fwcmd.chm

With previous FAR version these were working fine. After I've upgraded to FAR 3 Build 5254 x64, it stopped working.

I just discovered a workaround and now I changed my user menu to start c:\fwh\manual\fwcmd.chm

CHM file not opened in FAR 3 Build 5254 x64 from user menu

Posted: Wed 03 Oct, 2018 19:35
by topmo3
tomyam wrote:
Wed 03 Oct, 2018 07:12
it stopped working
more info would be better...

CHM file not opened in FAR 3 Build 5254 x64 from user menu

Posted: Wed 03 Oct, 2018 20:39
by Yegor
FarMenu.ini

Code: Select all

:    Test
     C:\Far\Encyclopedia\luafar_manual.chm
Works fine with Far 3.0 build 5273 x86 on Windows 10.0.17763.1 x64

CHM file not opened in FAR 3 Build 5254 x64 from user menu

Posted: Thu 04 Oct, 2018 03:44
by tomyam
topmo3 wrote:
Wed 03 Oct, 2018 19:35
more info would be better...
Thank you for your interest topmo3.

After selecting the option from the user menu I'll get the message,
' "fwcmd.chm" ' is not recognized as an internal or external command, operable program or batch file.
However if I navigate to the folder where the file is, selecting it by pressing Enter, it will appear as expected.

I'm using Windows 10 Pro x64 version 1803 Build 17134.285

CHM file not opened in FAR 3 Build 5254 x64 from user menu

Posted: Thu 04 Oct, 2018 12:58
by topmo3
Yegor wrote:
Wed 03 Oct, 2018 20:39
Works fine with Far 3.0 build 5273 x86 on Windows 10.0.17763.1 x64
Works fine too with Far 3.0 build 5279 x64 on Windows 7 x64

my FarMenu.ini :

Code: Select all

:    test-chm
     "D:\Program Files\Far3\Encyclopedia\macroapi_manual.en.chm"

CHM file not opened in FAR 3 Build 5254 x64 from user menu

Posted: Thu 04 Oct, 2018 13:06
by topmo3
tomyam,
check F9 - Command - File associations for *.chm

CHM file not opened in FAR 3 Build 5254 x64 from user menu

Posted: Fri 05 Oct, 2018 04:12
by tomyam
topmo3 wrote:
Thu 04 Oct, 2018 13:06
tomyam,
check F9 - Command - File associations for *.chm
Thank you! That solved the problem.