Page 3 of 4

InnoSetup module for Observer

Posted: Fri 12 Apr, 2019 15:59
by skipik

Latest post of the previous page:

Yeah, I also can't get in to this exe for example: https://github.com/telegramdesktop/tdes ... 6.beta.exe
The official 0.48 works fine though.

InnoSetup module for Observer

Posted: Fri 12 Apr, 2019 16:03
by pepak
Both seem to work fine in my x86 version, too, so it is likely a x64-only issue. Considering how the x64 version was made, I am not surprised we are running into trouble with some installers. I will look at them when I have the time.

InnoSetup module for Observer

Posted: Sun 14 Apr, 2019 09:06
by pepak
Fixed in 0.48.1.

InnoSetup module for Observer

Posted: Sat 18 May, 2019 06:33
by Yegor
Hi pepak, what about updating to 0.49? Thanks,

InnoSetup module for Observer

Posted: Sat 18 May, 2019 08:53
by pepak
Never noticed that. Yes, I will see about adding that support.

InnoSetup module for Observer

Posted: Sat 18 May, 2019 16:42
by pepak
Version 0.49.0 released: Synced with InnoUnp 0.49.

InnoSetup module for Observer

Posted: Mon 06 Apr, 2020 09:36
by Pasha_ZZZ
pepak wrote: Sat 18 May, 2019 16:42Version 0.49.0 released: Synced with InnoUnp 0.49.
There are official builds of Observer 1.12 from author - https://dl.bintray.com/lazyhamster/FAR-Plugins/

InnoSetup module for Observer

Posted: Tue 07 Apr, 2020 14:58
by pepak
Hmm. I have no way of veryfing that these are really official. They don't look like it and there's no indication at PlugRing that a new version has been released. The author's Github still only shows version 1.11.2. I will wait for an official release before making any modifications to the InnoSetup module.

InnoSetup module for Observer

Posted: Tue 07 Apr, 2020 15:42
by John Doe
Well, this is really build from plugin's author, see https://github.com/lazyhamster/Observer ... pveyor.yml
And you can rebuild from sources yourself.

But it is dev version, not release.

InnoSetup module for Observer

Posted: Tue 07 Apr, 2020 16:05
by Pasha_ZZZ
pepak wrote: Tue 07 Apr, 2020 14:58I have no way of veryfing that these are really official
Official topic (author) - viewtopic.php?f=5&t=4644&start=1980
And this link (by athor too):
Image
And about Github version - https://github.com/lazyhamster/Observer ... ersion.m4i

InnoSetup module for Observer

Posted: Wed 08 Apr, 2020 07:13
by Ariman
Bintray link contains last successful CI build from master branch. It is pretty much same thing as Far builds (but without history and git tags).

InnoSetup module for Observer

Posted: Wed 08 Apr, 2020 15:45
by pepak
In other words, it is official but it is not a release version. In that case, it really is not a good idea to release submodules for it - it would be confusing for users who download their files from Far Forums or PlugRing. If someone wants to stay at the cutting edge, they can of course compile the submodule themselves. IMO, this is a much better solution that building a submodule for a non-release code.

InnoSetup module for Observer

Posted: Thu 09 Apr, 2020 19:08
by Pasha_ZZZ
pepak wrote: Wed 08 Apr, 2020 15:45it really is not a good idea to release submodules for it
Maybe non-release submodule in addition to release? 1.12 contains important fixes f.e. unicode support. Current version 1.11.2 f.e. shows garbage in NSIS containers:
Image

InnoSetup module for Observer

Posted: Fri 10 Apr, 2020 06:25
by pepak
I really don't like that idea. Is there anything which prevents Observer 1.12 from being marked as an official release and uploaded here to PlugRing? Then I could update the sources and upload the submodule without any problems.

InnoSetup module for Observer

Posted: Sat 11 Apr, 2020 18:34
by skipik
pepak, https://github.com/lazyhamster/Observer/releases, 1.12 is final version now, please update your module. :)

InnoSetup module for Observer

Posted: Sun 12 Apr, 2020 10:29
by lordmuzer
And it was announced on forum viewtopic.php?p=160294#p160294
It was not uploaded to PlugRing due to some issues with PlugRing itself