Page 1 of 1

Ошибка при запуске Far 3 в Windows XP: Отказано в доступе, LuaMacro.dll.

Posted: Thu 31 Jan, 2019 14:26
by temp-n
При запуске Far выдается сообщение
  1. ╔══════════════════════ Ошибка ═══════════════════════╗
  2. ║             Ошибка при загрузке плагина             ║
  3. ║ C:\Program Files\Far3\Plugins\LuaMacro\LuaMacro.dll ║
  4. ╟─────────────────────────────────────────────────────╢
  5. ║                 Отказано в доступе                  ║
  6. ╟─────────────────────────────────────────────────────╢
  7. ║                       { OK }                        ║
  8. ╚═════════════════════════════════════════════════════╝
соответственно, не работает плагин FarColorer.

Far: 3.0 build 5354 x86
Система: Windows XP Professional SP 3

Версия 3.0 build 5100 не выдает ошибку, версии 3.0 build 5200 и далее - выдают.

Для пользователя установлены права на полный доступ. Пользователь - владелец файлов и член группы Администраторы.
Поиском ничего не нашлось (

Ошибка при запуске Far 3 в Windows XP: Отказано в доступе, LuaMacro.dll.

Posted: Thu 31 Jan, 2019 19:50
by Dennis_Moore
temp-n wrote:
Thu 31 Jan, 2019 14:26
Версия 3.0 build 5100 не выдает ошибку, версии 3.0 build 5200 и далее - выдают
Причина у вас, на XP все по-прежнему работает (b5356). Для ее выяснения попробуйте ProcMon из набора SysInternals.

Ошибка при запуске Far 3 в Windows XP: Отказано в доступе, LuaMacro.dll.

Posted: Thu 31 Jan, 2019 20:12
by DrKnS
temp-n wrote:
Thu 31 Jan, 2019 14:26
соответственно, не работает плагин FarColorer
Опа. А что, колорер уже зависит от луамакро?

Ошибка при запуске Far 3 в Windows XP: Отказано в доступе, LuaMacro.dll.

Posted: Fri 01 Feb, 2019 06:07
by ctapmex
проверил на xp sp3, xp x64 - все работает.
win 2000 - возникает указанная в теме ошибка. и far падает без ошибок/следов при входе в редактор. не важно с/без colorer

кстати, давайте где-нибудь зафиксируем, какие ОС поддерживаются в обязательном порядке, какие опционально .

Ошибка при запуске Far 3 в Windows XP: Отказано в доступе, LuaMacro.dll.

Posted: Fri 01 Feb, 2019 09:21
by Shmuel
Насколько я понимаю, сам Far.exe до сих пор поддерживает Win2K.
LuaMacro не поддерживает Win2K уже давно, но до сих пор поддерживает WinXP.
Почему у автора темы возникает эта ошибка - надо смотреть на его машине.

Ошибка при запуске Far 3 в Windows XP: Отказано в доступе, LuaMacro.dll.

Posted: Fri 01 Feb, 2019 09:32
by Dennis_Moore
ctapmex wrote:
Fri 01 Feb, 2019 06:07
win 2000 - возникает указанная в теме ошибка
Colorer на полностью обновленной Windows 2000 SP4 отлично работает, только NetBox и LuaMacro пишут The specified procedure could not be found.
ctapmex wrote:
Fri 01 Feb, 2019 06:07
кстати, давайте где-нибудь зафиксируем, какие ОС поддерживаются в обязательном порядке, какие опционально
А в чем различие между обязательно и опционально ? Например, два стандартных плагина и 80% сторонних на W2k не работают, но стоит применить врапперы о которых я писал здесь и все начинает работать. Если же FAR перевести на XP+ API то я не уверен что поддержка W2k сохраниться и даже врапперы могут не помочь.

Ошибка при запуске Far 3 в Windows XP: Отказано в доступе, LuaMacro.dll.

Posted: Fri 01 Feb, 2019 10:41
by ctapmex
Dennis_Moore wrote:
Fri 01 Feb, 2019 09:32
А в чем различие между обязательно и опционально ?
обязательно - всё входящее в поставку должно поддерживать.
опционально - сам far работает, остальное по желанию. либо отдельная сборка, либо описание что не держит/удалить

Ошибка при запуске Far 3 в Windows XP: Отказано в доступе, LuaMacro.dll.

Posted: Fri 01 Feb, 2019 14:10
by temp-n
Спасибо.
Обращения к файлам luafar3.dll и colorer.dll блокировались (почему-то без каких-либо сообщений) антивирусом AVG.