Проблема с обновлением msi-пакетом

Столкнулись с проблемой в использовании Far? Здесь можно получить помощь.
Post Reply
ckotick
Posts: 2
Joined: Sat 05 Dec, 2020 07:46

Проблема с обновлением msi-пакетом

Post by ckotick »

Всем добра.

Довольно продолжительное время на своей домашней системе (W7SP1x64) наблюдаю странное поведение установщика при обновлении. Если просто "жмякнуть" загруженный файл, то на выходе получается такое:
изображение.png
Даже если "сбросить" (и настроить компоненты как нужно), установка завершится ошибкой, т.к. повышение привилегий запрошено не будет, и доступа записи в папку программы нет.
Чтобы всё прошло гладко (подхват настроек существующей установки, успешное завершение), нужно сразу запустить установщик с повышением привилегий. Через проводник это затруднительно, через cmd несколько неудобно, с помощью самого Far – нормально, но нужно помнить, что его закрыть надо.
Также не работает должным образом удаление (без повышения). Установщик слегка шуршит, что-то делает, но файлы остаются на месте. При этом повторное "жмякание" установочного пакета изображает, что программа не установлена, и предлагает ставить с настройками по умолчанию (+запросит повышение).

У всего этого непотребства есть предыстория. Система какое-то время стояла на 60ГБ SSD, и с целью высвобождения места некоторый мусор (в т.ч. %SystemRoot%\Installer) был перенесён на HDD + созданы ссылки. Владельцы + разрешения NTFS на HDD сперва были корявые, но потом восстановлены до корректных по образцу (рабочая W7SP1x64).
Сейчас система перенесена на SSD нормального размера, проблем с местом нет, весь мусор перенесён на родные точки. Но моя дальнейшая возня с папкой Installer никакого эффекта на Far не оказывает. Даже удаление (переименование) Installer, и установка Far в девственно чистую всё равно в итоге закончится так же - первое же обновление, и см. картинку + пояснение.

При обновлении/удалении другого ПО, использующего msi, с таким поведением не сталкиваюсь. Пока были кривые разрешения на ссылке в HDD, LibreOffice вёл себя похожим образом. Сейчас, кроме Far, ни один продукт так себя не ведёт.

Можно ли это как-то излечить способом отличным от переустановки системы?
ckotick
Posts: 2
Joined: Sat 05 Dec, 2020 07:46

Проблема с обновлением msi-пакетом

Post by ckotick »

Тут журналы с домашней системы:
home.zip
(12.81 KiB) Downloaded 16 times
Тут с рабочей:
work.zip
(12.3 KiB) Downloaded 14 times
И с домашней установка LO без предварительного повышения привилегий:
lo_unelevated.zip
(108.38 KiB) Downloaded 16 times
У FM на домашней системе без предварительного повышения все состояния компонентов почему-то мигрируются как Advertised вместо Local.
Где ещё чего поискать? В реестрах систем вижу различие: названия разделов Products для FM разные, для LO одинаковые. После переустановки FM дома название его раздела изменилось. Поведение при обновлении - нет.
Post Reply

Return to “Нужна помощь”