wfx2far

Здесь можно обсудить ваш любимый плагин.
Post Reply
maxdrfl
Posts: 484
Joined: Mon 04 Apr, 2005 14:36
Location: Иркутск

Post by maxdrfl »

Latest post of the previous page:

4ekucT, нашел. С пробелами все нормально. Проблемы с кириллицей в именах файлов. Интересно что русские каталоги он создает на диске пустые, а вот файлы не находит.

mi3antrop
Posts: 49
Joined: Tue 15 Nov, 2005 18:31
Contact:

Post by mi3antrop »

А у меня TCBurner в wfx2far в своем корневом каталоге показывает названия "файлов" и "папок" пустыми.
CtrlEnter выдает пустое сообщение с птичкой на кнопке, ShiftEnter - никакой реакции, в "каталоги" (ну те, которые с пустыми названиями) не входит - перескакивает на .. , то же с "файлами".
А после того как любую описанную манипуляцию в нем произвел, при закрытии фара выдается какое-то сообщение об ошибке, неверное, на немецком, поэтому повторить не берусь (фрагменты: ... по адресу 77FCC2E2 в модуле ntdll.dll ... по адресу 0AA10010.)
В тотале все работает на ура.
Win 2000 и XP.
Во вложении снэпшот. Курсора не видно, но по пустым "папкам" перемещается.
Attachments
sshot.zip
скрин
(513 Bytes) Downloaded 292 times

User avatar
4ekucT
Posts: 507
Joined: Tue 05 Apr, 2005 23:44
Location: Беларусь, Минск

Post by 4ekucT »

Кароче хрен его знает =)) приду домой посмотрю...

Kildor
Posts: 1515
Joined: Wed 16 Mar, 2005 06:26
Location: Новосибирск
Been thanked: 1 time
Contact:

Post by Kildor »

Поставил (не багфикс), запустил фар, появился диалог „поиск плагинов wfx” (стандартный текст), диалог исчез, окно фара потеряло фокус.
Перегрузил фар, фокус слетел опять…
Бага однако, причём очень назойливая бага…
Ты мне не выкай!
«ФарФорум не для пользователей!»
Upd:
P.S. Я просто поддерживаю беседу.» © Народ.

xmpp:kildor@jabber.ru

User avatar
4ekucT
Posts: 507
Joined: Tue 05 Apr, 2005 23:44
Location: Беларусь, Минск

Post by 4ekucT »

Надо ставить ПОСЛЕДНЕЕ... Малоли что я там наделал.

User avatar
4ekucT
Posts: 507
Joined: Tue 05 Apr, 2005 23:44
Location: Беларусь, Минск

Post by 4ekucT »

Насчет бурнера с русскими хез наверное нереально потому как фар юзает файловую систему в OEM...

maxdrfl
Posts: 484
Joined: Mon 04 Apr, 2005 14:36
Location: Иркутск

Post by maxdrfl »

Подтверждаю: потеря фокуса фара с последним пофиксеном билдом плагина.

4ekucT, может быть, но папки с русскими буквами он нормально понимает, а вот сам файл найти не может.

User avatar
4ekucT
Posts: 507
Joined: Tue 05 Apr, 2005 23:44
Location: Беларусь, Минск

Post by 4ekucT »

Даблин, дело в том что в тотале он пишет все чики-пики... Вот такая хрень. Тут маза в том что я после вызова каждой функции фар апи делаю - SetFileApisToANSI(); - а потом перед возвратом назад - SetFileApisToOEM(); Все имена приходящие из фара я перегоняю из OEM - OemToChar(pi.PanelItems[pi.CurrentItem].FindData.cFileName,pi.PanelItems[pi.CurrentItem].FindData.cFileName);

Если этого не делать то с русскими файлами вообще не работало. Скорее всего трабл пояляется изза того что когда мы начинаем писать болванку, мы уже выходим из функции фара, то есть переводим файловую систему назад в OEM для нашего процесса (Far.exe). Я попробую поэксперементировать, но если это немодальный диалог то скорее всего ничего не получиться... иначе в фаре будут повсюду иероглифы.

User avatar
4ekucT
Posts: 507
Joined: Tue 05 Apr, 2005 23:44
Location: Беларусь, Минск

Post by 4ekucT »

Проверяйте... Думаю все получилось =))

maxdrfl
Posts: 484
Joined: Mon 04 Apr, 2005 14:36
Location: Иркутск

Post by maxdrfl »

Теперь стало еще интересней. Сначала говорилось что файл занят другим процессом. Потом удалось записать диск. Первая папка с содержимым записалась нормально. Остальные папки - пустые, файлы не записались.

ISO образы делаются нормально.

Потеря фокуса фаром осталась.

ЗЫ. Вот такие вот дела.

User avatar
4ekucT
Posts: 507
Joined: Tue 05 Apr, 2005 23:44
Location: Беларусь, Минск

Post by 4ekucT »

Так насчет фокуса - это скорее всего гадит какойто wfx плугин при загрузке. Попробуй отрубить поиск плугинов при старте, если все будит ок, я вырублю эту фичу по дефолту.

User avatar
4ekucT
Posts: 507
Joined: Tue 05 Apr, 2005 23:44
Location: Беларусь, Минск

Post by 4ekucT »

Так насчет записи - делай бурн по ShiftEnter и нажимай ввод только после того как запищутся все данные. У меня получилось для большего объема русских файлов. Просто я ж говорю при возвращении управления фару устанавливается OEM для файловой системы. Кароче если такие баги будут поялвяться для некотрых плугинов, для них надо будет использовать запуск по ShiftEnter

maxdrfl
Posts: 484
Joined: Mon 04 Apr, 2005 14:36
Location: Иркутск

Post by maxdrfl »

у меня загрузка при старте отключена всегда...

За совет спасибо, попробую. Три раза тебе КУ

maxdrfl
Posts: 484
Joined: Mon 04 Apr, 2005 14:36
Location: Иркутск

Post by maxdrfl »

ну все, запись заработала. Финальное спасибо.

а вот потеря фокуса остается даже при полном отсутствии подплагинов.

User avatar
4ekucT
Posts: 507
Joined: Tue 05 Apr, 2005 23:44
Location: Беларусь, Минск

Post by 4ekucT »

Гыы просто у меня такой потери фокуса нету... Поэтому я ее и поправить не могу =))

maxdrfl
Posts: 484
Joined: Mon 04 Apr, 2005 14:36
Location: Иркутск

Post by maxdrfl »

гы, он проявляется только если отключить проверку плагинов при старте, иначе - нормально :)

Post Reply

Return to “Обсуждение плагинов”