Page 2 of 2

UM Adapter — пакет для использования пакетов из LuaFAR for Editor в LuaMacro

Posted: Thu 02 Jun, 2016 18:14
by sToLp

Latest post of the previous page:

Aidar wrote:Проще назначить в макросах комбинации клавиш на целые меню или отдельные пункты.
...
Другой вариант — создать свой LUM со своими пунктами и только его выводить.
Хорошо. Спасибо за информацию. Буду пробовать делать так.

UM Adapter — пакет для использования пакетов из LuaFAR for Editor в LuaMacro

Posted: Sat 18 Feb, 2017 14:19
by Dennis_Moore
Использую UM Adapter вместе с Rh_Scripts и fl_Scripts и столкнулся с неработоспособностью фильтра панели. При вызове "Panel filter" после ввода любого символа получаем такую ошибку:



Следующее относится уже к fl_scripts, но размещу здесь, а оставить или перенести в тему fl_scripts уже на усмотрение модератора

В LuaFar for Editor фильтр не выдает ошибок но фильтрует неправильно т.к. устанавливает аттрибут compressed. Ошибка в файле \fl_scripts\panels\panelfilter.lua очевидно в строках 27 и 28.

P.S. FAR3 b4898, UM Adapter 3.0.1.0, fl_scripts 3.1.0.0

UM Adapter — пакет для использования пакетов из LuaFAR for Editor в LuaMacro

Posted: Sat 18 Feb, 2017 15:15
by Shmuel
Насчёт Panel Filter - он есть и в другом варианте - переделанный в макрос (http://forum.farmanager.com/viewtopic.p ... 43#p134643). Не пробовали?

UM Adapter — пакет для использования пакетов из LuaFAR for Editor в LuaMacro

Posted: Sat 18 Feb, 2017 16:59
by Dennis_Moore
Если в \work\scripts\fl_scripts\cfg\hotkeys_config.lua
закомментировать любые строки, кроме smarthome и smarttab, то после lm:load (или перезапуска FAR) получим такую ошибку:

Code: Select all

╔═════════ AddToMenu ═════════╗
║ Key `' is already allocated ║
╟─────────────────────────────╢
║           { OK }            ║
╚═════════════════════════════╝
Далог с этой ошибкой появляется столько же раз сколько закомментировано строк. Если fl_scripts подключен к LFE то все нормально т.ч. баг наверное в UM Adapter.

Upd. Попробовал пустые значения - не помогает.

UM Adapter — пакет для использования пакетов из LuaFAR for Editor в LuaMacro

Posted: Sun 19 Feb, 2017 18:51
by Dennis_Moore
Решил свою проблему из предыдущего сообщения.
Например мне нужно убрать хоткеи для комментариев т.к. я предпочитаю MBlockEditor.

1) Комментируем эти строки в \work\scripts\fl_scripts\cfg\hotkeys_config.lua:

Code: Select all

autocomment            = 'Alt+Shift+C', 
autouncomment          = 'Ctrl+Shift+C',
2) Комментируем четыре строки в \work\scripts\fl_scripts\_usermenu.lua.example которые относятся к комментариям:

Code: Select all

comment         = { file="comment",           area='e'        },

{ name="Comments",       key=nil, script=scripts.comment },

{ name='AutoComment',    hide=true, key=hotkeys.autocomment, script=scripts.comment, argument='comment' },

{ name='AutoUnComment',  hide=true, key=hotkeys.autouncomment, script=scripts.comment, argument='uncomment' },
И по тому же принципу остальное. В LFE работало потому что там я проблему решил но благополучно об этом забыл.

UM Adapter — пакет для использования пакетов из LuaFAR for Editor в LuaMacro

Posted: Sat 29 Dec, 2018 11:23
by Dennis_Moore
Обновил FAR, обновил Rh Scripts и увидел что при заходе в LUM for Editor и fl scripts LUM сыпятся ошибки и решил спросить: а совместимы ли они споследними билдами FAR и LuaMacro ?

LUM for Editor:


fl scripts LUM:


Upd:
FAR 5344
Rh Scripts 3.3.6.5
UM Adapter 3.0.2.1

UM Adapter — пакет для использования пакетов из LuaFAR for Editor в LuaMacro

Posted: Sat 29 Dec, 2018 14:13
by Aidar
Dennis_Moore
Спасибо за сообщение. Я редко обновляю FAR.
Постараюсь посмотреть в ближайшее время.
Если есть какие-то подробности по ошибке, можно написать в личку.

UM Adapter — пакет для использования пакетов из LuaFAR for Editor в LuaMacro

Posted: Sat 29 Dec, 2018 16:47
by Aidar
Попробуйте в файле RhScrits\Utils\Utils.lua поменять строку

Code: Select all

  return far.AdvControl(F.ACTL_GETFARVERSION, kind)
на

Code: Select all

  return far.AdvControl(F.ACTL_GETFARMANAGERVERSION or F.ACTL_GETFARVERSION, kind)

UM Adapter — пакет для использования пакетов из LuaFAR for Editor в LuaMacro

Posted: Sun 30 Dec, 2018 01:38
by buniak_a_h
Aidar wrote:
Sat 29 Dec, 2018 16:47
F.ACTL_GETFARVERSION
Нет такого флага...В версии 5346, во всяком случае

UM Adapter — пакет для использования пакетов из LuaFAR for Editor в LuaMacro

Posted: Sun 30 Dec, 2018 07:04
by Aidar
buniak_a_h.
Это я оставил для совместимости с версией v.3.0.4575, пока не проверю совместимость с v.3.0.5346.

UM Adapter — пакет для использования пакетов из LuaFAR for Editor в LuaMacro

Posted: Sun 30 Dec, 2018 11:21
by Dennis_Moore
Aidar wrote:
Sat 29 Dec, 2018 16:47
Попробуйте в файле RhScrits\Utils\Utils.lua поменять строку
Спасибо, помогло. Я правда не всеми возможностями пользуюсь, но то что я использую рабтает.