Editor settings - Default code page - default UTF8 no BOM

Something is missing in Far Manager? You have a great idea that should be heard? Write here.
Post Reply
Duhaczek2
Posts: 3
Joined: Wed 02 Jan, 2019 12:02

Editor settings - Default code page - default UTF8 no BOM

Post by Duhaczek2 »

I'm missing an option in the editor - when UTF-8 is default in settings "Default code page" I'd like to specify "Add BOM signature" = No
buniak_a_h
Posts: 3205
Joined: Sat 20 Apr, 2013 00:17
Location: Санкт-Петробад
Has thanked: 169 times
Been thanked: 468 times
Contact:

Editor settings - Default code page - default UTF8 no BOM

Post by buniak_a_h »

Next script solves your problem:
Last edited by buniak_a_h on Wed 10 Nov, 2021 11:20, edited 8 times in total.
2useven10
Posts: 4407
Joined: Mon 07 Sep, 2009 10:40
Has thanked: 7 times
Been thanked: 227 times

Editor settings - Default code page - default UTF8 no BOM

Post by 2useven10 »

Duhaczek2,
far:config <Enter>
select Editor.AddUnicodeBOM then press <Enter> to change boolean value (should be false)
Last edited by 2useven10 on Wed 10 Nov, 2021 10:49, edited 1 time in total.
2useven10
Posts: 4407
Joined: Mon 07 Sep, 2009 10:40
Has thanked: 7 times
Been thanked: 227 times

Editor settings - Default code page - default UTF8 no BOM

Post by 2useven10 »

This setting works unconditionally (not only when UTF-8 is default codepage) for newly created files.
If file already has BOM signature setting does not effect.
Post Reply

Return to “Suggestions and Ideas”