True Template

Здесь можно обсудить ваш любимый плагин.
Игорь Юдинцев
Posts: 725
Joined: Sun 03 Apr, 2005 22:00
Location: Казань
Been thanked: 1 time

Re: True Template

Post by Игорь Юдинцев » Tue 26 Aug, 2014 22:35

Latest post of the previous page:

Wave,
как воспроизвести? 8.1, Far x86 4067, не падает.
UPD: удалил устаревшую DLL

User avatar
4ekucT
Posts: 507
Joined: Tue 05 Apr, 2005 23:44
Location: Беларусь, Минск

Re: True Template

Post by 4ekucT » Wed 27 Aug, 2014 02:25

Игорь Юдинцев wrote:Wave,
как воспроизвести? 8.1, Far x86 4067, не падает.
Там скорее всего надо или файл глянуть редактируемый (или на всех падает?) или конфиги (с конфигами из коробки тоже падает?). Если не поможет, исследовать вырубанием по очереди всего до голого состояния Far + TT
Игорь Юдинцев wrote: вот версия для проверки, ест вдвое меньше стека:
Твои изменения добавлю на выходных в основную ветку

tstr
Posts: 524
Joined: Thu 16 Apr, 2009 16:15
Has thanked: 7 times
Been thanked: 6 times

Re: True Template

Post by tstr » Wed 27 Aug, 2014 06:17

tstr wrote:После билда 4040 при наличии плагина TrueTemplate (актуальная версия с PlugRing для FAR3) на чистом профиле и стандартных конфигах TrueTemplate и Colorer, в настройках Colorer ставим "[x] Change Editor background", во время открытия любого файла на редактирование падаем с трап-логом
FarTrap_20140813114112.7z
на IA32 и AMD64 версиях поведение одинаковое.
Не исключено, что "виноват" плагин TrueTemplate, хотелось бы установить источник проблемы.
zg wrote:true template зачем-то посылает пустой кейивент в ee_read. колорер не ожидает ProcessEditorInputW с неинициализированным editorSet.
Игорь Юдинцев wrote:Wave,
как воспроизвести? 8.1, Far x86 4067, не падает.
вот версия для проверки, ест вдвое меньше стека:
падает

воспроизвести - чистый профиль, фар после билда 4040, настройка при которой падает - "[x] Change Editor background" в колорере, если псису убрать - не падает. на всех трутемплейтах с марта, на обоих платформах.

Игорь Юдинцев
Posts: 725
Joined: Sun 03 Apr, 2005 22:00
Location: Казань
Been thanked: 1 time

Re: True Template

Post by Игорь Юдинцев » Wed 27 Aug, 2014 07:33

Закомментировал пустой KeyEvent:

tstr
Posts: 524
Joined: Thu 16 Apr, 2009 16:15
Has thanked: 7 times
Been thanked: 6 times

Re: True Template

Post by tstr » Wed 27 Aug, 2014 07:48

падения при открытии файлов прекратились.

User avatar
Wave
Posts: 1767
Joined: Thu 04 Aug, 2005 18:47
Has thanked: 4 times
Been thanked: 15 times

Re: True Template

Post by Wave » Wed 27 Aug, 2014 10:36

На версии с прошлой страницы и на сегодняшней падать перестало.
XPx86. Падало не только на колорере. Выгружал колорер — падало на визуалайзере, выгружал визуалайзер — падало на чём-то другом. На всех файлах.

Обратил внимание, что плагин сильно ест память. Запуск ФАРа и открытие одного и того же html-файла в 50 кб с и без тру темплейта:
22мб → 195мб
22мб → 44мб
Пользуюсь ФАРом больше 20 лет © собирательный.

Hiro
Posts: 1
Joined: Fri 05 Sep, 2014 15:30

Re: True Template

Post by Hiro » Fri 05 Sep, 2014 15:40

Helo, I'm hope that this is right place to put my question :)

I created my own configuration - template that should work on each file type. Simplyfied file look like this example:
  1. <TrueTpl>
  2.   <Language File="*.*" ignoreCase="0" Desc="My own shortcuts">
  3.     <Include File="templates\true-defines.xml"/>
  4.     <Include File="templates\true-global.xml"/>
  5.  
  6.     <Expand Name="sample"  At="&AnyWhere;" Pattern="s"    To="Sample string"/>
  7.   </Language>
  8. </TrueTpl>
Problem is that when I put to main true-tpl.xml file include line on begining: <Include File="templates\sample.xml"/> it will disable all other templates.
When I put it at the end, it is never automatically activated. And at last when I put it before <Include File="templates\true-default.xml"/> I never have default templates.

My question is if is possible to have my template active always - when editing any file type. Where to put it?
Last edited by Hiro on Thu 01 Jan, 1970 01:00, edited 0 times in total.
Reason: [codebox=xml file=untitled.xml], [c]

User avatar
Wave
Posts: 1767
Joined: Thu 04 Aug, 2005 18:47
Has thanked: 4 times
Been thanked: 15 times

Re: True Template

Post by Wave » Sat 06 Sep, 2014 17:46

Неплохо бы в xml-ки шаблонов вставить bom-сигнатуры.
Пользуюсь ФАРом больше 20 лет © собирательный.

Игорь Юдинцев
Posts: 725
Joined: Sun 03 Apr, 2005 22:00
Location: Казань
Been thanked: 1 time

Re: True Template

Post by Игорь Юдинцев » Tue 09 Sep, 2014 20:43

(UPD: удалена устаревшая версия dll)

User avatar
4ekucT
Posts: 507
Joined: Tue 05 Apr, 2005 23:44
Location: Беларусь, Минск

Re: True Template

Post by 4ekucT » Mon 22 Sep, 2014 00:15

Игорь, попробуй создать C++ файл по Shift-F4 и выбрать скажем шаблон Console Application. Откроется редактор с шаблоном, но там повсюду вставлены левые символы 0xFEFF (в начале, перед описанием, перед File ID). Видать вставка шаблонов как то некорректно работает.

tstr
Posts: 524
Joined: Thu 16 Apr, 2009 16:15
Has thanked: 7 times
Been thanked: 6 times

Re: True Template

Post by tstr » Mon 22 Sep, 2014 04:50

а какая общая схема хранения и вставки шаблонов относительно кодировок?
не могу понять как _должны_ вставляться в файлы разных кодировок шаблоны в разных кодировках.

Игорь Юдинцев
Posts: 725
Joined: Sun 03 Apr, 2005 22:00
Location: Казань
Been thanked: 1 time

Re: True Template

Post by Игорь Юдинцев » Mon 22 Sep, 2014 06:39

4ekucT wrote:Игорь, попробуй создать C++ файл по Shift-F4 и выбрать скажем шаблон Console Application. Откроется редактор с шаблоном, но там повсюду вставлены левые символы 0xFEFF (в начале, перед описанием, перед File ID). Видать вставка шаблонов как то некорректно работает.
Не воспроизводится; похоже на DLL версии ниже 3.0.1.5.
tstr wrote:а какая общая схема хранения и вставки шаблонов относительно кодировок?
не могу понять как _должны_ вставляться в файлы разных кодировок шаблоны в разных кодировках.
В шаблонах поддерживается только 1200.

tstr
Posts: 524
Joined: Thu 16 Apr, 2009 16:15
Has thanked: 7 times
Been thanked: 6 times

Re: True Template

Post by tstr » Mon 22 Sep, 2014 08:22

ясно.

из непонятного с кодировками хотелось бы выяснить как запускаются внешние процессы с потоковой обработкой: в какой кодировке передаётся и ожидается поток.

в хотелки, если принимаются:

1. по аналогу с колорер, у которого можно указать свой, не перезаписываемый при обновлениях Catalog.xml, (в настрройках указываем например %FARPROFILE%\Colorer\Catalog_custom.xml ), хотелось бы иметь аналогичную возможность в ТТ.

2. в путях (навскид - в конструкциях типа <Include File="templates\true-defines.xml"/>, To="\i'$\templates\text\shortcut.url'"/>) разворачивать переменные окружения

User avatar
4ekucT
Posts: 507
Joined: Tue 05 Apr, 2005 23:44
Location: Беларусь, Минск

Re: True Template

Post by 4ekucT » Mon 22 Sep, 2014 22:23

Игорь Юдинцев wrote:
4ekucT wrote:Игорь, попробуй создать C++ файл по Shift-F4 и выбрать скажем шаблон Console Application. Откроется редактор с шаблоном, но там повсюду вставлены левые символы 0xFEFF (в начале, перед описанием, перед File ID). Видать вставка шаблонов как то некорректно работает.
Не воспроизводится; похоже на DLL версии ниже 3.0.1.5.
Обновил Far до 4117, перебилдил плагин - все работает!

Так же добавил шаблоны для XML, XLST с валидацией и форматированием через tidy.sourceforge.net

User avatar
ur4ltz
Posts: 76
Joined: Fri 08 Jan, 2010 14:07
Location: Харьков
Has thanked: 1 time

Re: True Template

Post by ur4ltz » Wed 08 Oct, 2014 16:57

А можно собрать плаг без комманд SSE2?
У меня AMD их не понимает.. ((

petcz
Posts: 2
Joined: Tue 03 Feb, 2015 10:03

True Template

Post by petcz » Tue 03 Feb, 2015 10:54

Здорово!
Помогите, плиз. Sorry I have very weak knowledge of Russian language so I am writing in English. First of all, thank you for great plugin for Far. I have a little problem that was maybe already solved in the forum, but I was not able to find it. I am not able to use backslash '\' in expand elements. I was trying '\\', '\\\', even html entity '& # 9 2 ;', but none of these works - it simply does not write the backslash symbol. It's not working even for existing templates e.g. true-source-c#-base.xml. Did I missed something? Is there some simple solution? I am running on Win 8.1, Far 3.0 4040, True Template v. 3.0.1.6 and 3.0.1.8

спасибо

Игорь Юдинцев
Posts: 725
Joined: Sun 03 Apr, 2005 22:00
Location: Казань
Been thanked: 1 time

True Template

Post by Игорь Юдинцев » Thu 05 Feb, 2015 00:57

petcz wrote:I am not able to use backslash '\' in expand elements. I was trying '\\', '\\\', even html entity '& # 9 2 ;', but none of these works - it simply does not write the backslash symbol.
It appears to be a parsing bug, I'll check that out.

Post Reply

Return to “Обсуждение плагинов”